留言板

关于落格的任何问题都可以在这里留言!

耻辱柱

[PGP]lomyr.jo#gmail.com

“留言板”的185个回复

  1. 你好,我买了一个iphone的落格,经过一周渐渐习惯,想把mac上也用上,所以百度了很久下载后发现没有小浪布局的,并且不知道哪里处理,且提示我7天试用期,还要另外购买吗?真心想使用

  2. 今天购买了ipad上的两个落格输入法,但是不会使用。现在又下载了一个
    Mac的落格输入法,终于会用了一小点。但是存在一些问题:
    1 s 丨 个 中 丰 书 旧 北 由 甲 申 师 串 非 临 畅 丵 丫 丩 丱
    的mac中可以定义,但不能够在第一个位置。可以一次输出来。
    2 落格输入法,只能输出一个字。
    3 Mac的拼音输入法,定义:bco 可以输出:日 月 星 云 春 夏 秋 冬 田 石 山 草 果 木 花 鸟 虫 鱼
    4 落格输入法,只能输出一个字:日。但是,可以看见:日 月 星 云 春 夏 秋 冬 田 石 山 草 果 木 花 鸟 虫 鱼。
    5 才在Mac上使用,就显示出才能够使用一个星期。
    希望能够方便的让购买了的可以使用。这个是最重要的事情。
    谢谢!

    1. 目前来说,还真不具备这样的功能。我对符号这方面理解不足,落格输入法仅能输入自带的那些符号。如果你需要输入其他特殊符号,那么只能用点划或者用户编码自定。

  3. 你好~~你的部落格真的寫的太好了….我是一個UI設計師現在自學SWIFT CODE 希望有一天可以自己設計自己做出我的APP….

    目前一直搞不懂Stack view…一直用但是我的label還是一直亂飛,大小也調整的不是我要的感覺~~><~~~

    請問可以寫信請教你問題嗎?..感謝

  4. 提个建议,网站首页没有明显的下载按钮,让人好找。买了iOS版本的,之前的没接触过双拼,现在还想要个Mac的学生码。

  5. 1:已经入手Ios版本,以下内容我是有自然码输入的(IOS为了用app我放弃了2 年的小鹤双拼转自然码,一边查码有边输入)
    ,作者可以开发个linux版本的啊。现在用的是linux搜狗版本的,不能用辅助码直接上屏。我喜欢直接上字,不喜欢用候选词。
    2:作者我也在学编程,我看你的博客分栏语言是swif,java,和C语言。我现在学的是java,以后方便可以和你探讨下语言技术啊。3我的学习语言目标是java python go。

    1. 哈哈,语言只是工具,我会的语言也不少………………Linux版本要在比较长远的未来开发,毕竟是免费的东西,我如果现在就全力开发Linux版本,下个月就得去喝西北风了。感谢你的支持呢~开发上有任何问题随时可以来交流呀!

  6. 大大,我在看你的关于openwrt的刷机及安装插件的文章。
    我有两台路由器,N16和TP的WR720N。
    都已经刷了系统了,N16的SS插件也搞进去了。就是不能SS。我也是Linode的服务器,单机使用跟另一台AC68U都用得很好。
    实在搞不下去了,请指教。

      1. 我刚下下来,还在7天试用中。。。并且,我想问,搜狗双拼需要用到;(ing)键,但是,它貌似跟落格的什么东西冲突了,请问如何设置?

      2. 你好,我是一个大陆音乐学生,全家人对翻墙很以来,刚刚搜索到你写的做VPN的文章,奈何实在看不懂也无法实践,可以请您远程跟我讲解如何做一个VPN吗,带薪的Orz,请联络我的Mail

        1. 这个吧……我建议你还是看我博客右下角的有情推广,在里边找一个ss的服务购买使用,不要自己搭建。vpn现在没有能用的了,全部都是秒断。

  7. 尊敬的落格输入法开发者您好,我们是一群视障者”盲人”用户,也许您在前段时间和我们这个群体的其他用户接触过,因为iOS下的落格输入法是视障者用户唯一一款可以使用的双拼输入法。
    这段时间我们发现您上线了Mac版本的落格输入法,但Mac下版本的落格存在不兼容voiceover的情况,目前最大的问题就是在开启voiceover状态下,使用光标选择候选字词,voiceover无法朗读被候选的字词。
    希望能早日解决对于voiceover的兼容性问题,我们很乐意为这样优秀的应用付费。

    1. 是的,落格输入法 macOS 现在还是有这个问题的。对于 VoiceOver 的支持是有计划的,但目前主要还在完善更多功能,这些东西有个先后的顺序问题,希望您能够理解,毕竟开发是一个过程问题哈,但我想让您知道的是 VoiceOver 的兼容和支持是在计划中的,这个一定会有。

  8. 哈啰
    我是 Mac 版用户,反映两个小问题:
    1.用快捷键时,按到 shift 键,误触发落格中英切换;
    2.菜单栏中的自定义编码、自定义引导符时常点击无反应

  9. 我用五笔的,之前一直使用百度,偶然看到落格最接进原生输入法界面,就付费下载了,缺点每次键盘跳出来的时候都会闪一下,在实险室中“在输入框内显示Buffer,这个很惊艳,但是时不时的就失效了,还有就是通录入导入,是全部拼音的,完全不是五笔。

    1. 我无法智能生成五笔的编码,所以就是拼音了。关于键盘闪的问题,请移步这里查看。inlinebuffer功能是我自己魔改实现,在浏览器的web页面里的输入框可能不那么好用,这也是它在实验室里的原因:)苹果本身并没有给这个权限的。

      1. 名字自动五笔的编码不能用五笔词组的方式生成吗?两个字是每个字的前两码,三个字是是前两个字的第一码和第三个字的前两码,三个以上是是前三个字的第一码和最后一个字的第一码。五笔的词组就是这个规则,可以弄成这样不?

          1. 字库不存在 这个没办法解决了,即使是拼音也有这个问题吧,比如拼音库里也没这个字,那也无法为这个词造个码。
            不同五笔编码的组词方式一样。
            前面的回复是用手机打的,可能没表达清楚:
            比如要组个词
            狗蛋 狗:qtqk 蛋:nhju ,各取前两码,成: qtnh 就是这个词了
            狗蛋儿 儿:qtn 取前两个字的前一码 q+n,和最后一个字的前两码+qt,成 qnqt
            狗儿蛋子 子:bb 取每个字的第一码,就是qqnb

            我刚查了一下新世纪五笔,也是这个规则。

            如果是对于一个字本身不同编码下字码不同,我不知道你的产品是怎么设计的,我猜想是根据当前用户使用的五笔版本来造吧。虽然这个在用户切换了版本的情况下就不能用了。

          2. 你要不提我还真不知道有这个版本的五笔。五笔学习曲线太陡,发布多个版本改动较大反而不利于五笔的普及。不知道五笔作者怎么想的。

          3. 每个人心里都有一款自己的输入法,于是……就有了落格输入法,哈哈哈哈。总之,我其实是比较能体会和理解的啦~

  10. 您好,小鹤双拼用户,刚刚购买了IOS落格输入法发现内置无小鹤方案,且对数表中搜索不到其他用户上传的小鹤方案,请问若想使用小鹤方案是否只能通过添加自定义方案来部署?

  11. 大大,我的MacBook Pro (Retina, 15-inch, Mid 2015),系统版本10.12.4 (16E195),下班后如果不关闭wifi,直接盖上盖子,第二天早上来上班,就会掉10%左右的电,关闭wifi睡眠耗电就正常,这样已经很久了,查看控制台,发现没几分钟就会被weakup一下,似乎来自tcp的,比较早用13寸macbook pro的时候没有发现这样的情况,找不到原因,除了重装系统,请问我还能做什么来帮助我找到耗电原因?

  12. 你好,我在弄openwrt到了opkg update不行,反复测试是op的网还没弄好不能直接下载,正好看到你的技术帖https://www.logcg.com/archives/596.html, 我 ifconfig里偏偏没有eth1(”wan”),我百度了下没解决,也改了OP的LAN口地址设置,希望能得到帮助,是通过电子邮件回复我吗?

  13. 落格大侠,再来请教个问题,就是wordpress中如何将页面或文章中的默认显示的下划线去掉,等鼠标移动到超级链接的时候再显示下划线并且更换链接文字的颜色,请问这个功能怎么实现呢,照着网上回答的说更改为none根本不起作用,谢谢大侠了;还有个问题就是如何在页面中或文章中调用最新的文章列表,如在指定行显示最近3-5篇的最近文章并且控制显示字数呢,非常感谢!

    1. a:link, a:visited { color: #3C3F36; }
      很遗憾,我没有找到怎么修改这个链接的样式,我在主题自己的源码里看到他们并没有使用 text-decoration(本身就已经是none了)
      不过链接划过的颜色……也不能进行控制,很奇怪,唯一能够生效的就是链接的颜色,通过上面那条语句可以控制链接的颜色,但鼠标划过的颜色还是默认的,很遗憾我只会这么多哈。

  14. 我是臺灣少數雙拼使用者。當初抱著終於可以擺脫百度跟搜狗的希望買了。試用了一下,除了繁體的問題,這款輸入法我真的超愛,很多功能都是我一直想要的。但很可惜,我實在是無法容忍繁體輸出的問題,所以我短時間內大概也不會用了。(看到繁體輸出的問題,心情像是被分手的感覺QQ)不過無論如何我都能感受到你們開發的熱情,希望你們繼續加油,讓這個輸入法越來越好 :3!

    1. 繁体字的转换是基于字来的,所以很多词汇可能会不正确 XD 毕竟输入法的后台数据库其实是简体字,因为我自己只能认繁体不会写……
      以后我会努力想办法改变这一现状……(虽然现在还没有头绪) 总之,谢谢你的支持我的朋友!

  15. 你好,我几次想要尝试双拼输入法。但mac上对第三方输入法支持不错,ios上就比较坑了。第三方输入法(百度、搜狗)经常会无响应,或者在锁屏界面中无法加载出来,导致使用体验极差,我不得不用回原生输入法,这样一来也就无法维持全平台使用双拼了。

    不知道落格输入法在这些方面是否有优势呢?我认为你平时也是在ios上用自己的双拼输入法的,你在这些方面的感受体验如何?能否介绍一二?

    1. 首先,锁屏界面中,第三方输入法都是无法使用的:)

      我在写落格输入法之前,一直用的是搜狗,说实在的我现在也觉得它好用XD,在iOS平台开发第三方输入法半年了,我对苹果的这个输入框架多少也算有了了解,可以说,第三方输入法卡顿是必然的。——苹果自身对它的优化就不够。(iOS10开始优化力度还是挺明显的。)

      我的输入法可能在你说的这些方面都没有优势,它呼出比搜狗还卡(会明显地跳一下),是由于我用了自动布局导致的(你看,他们自家推广的技术,然而性能并不行。)

      我用双拼最喜欢的部分是辅码,它能能够允许我快速筛选想要的词汇,这一点我在文章中多次提到,而遗憾的是几乎所有的输入法都不支持这个功能,比如搜狗百度之类的。mac自带很好用,但遗憾的是也不支持。我在mac上用手心,偶尔用自带,应该说是来回用。 ios我是6s,中文就用落格输入法,不使用主码表,就用词库和辅码,妥妥的!
      英文用系统自带不能更完美。

      当然,很多用户觉得没有纠错和奇奇怪怪的键盘布局是一大遗憾,我自己只用qwerty所以不觉得哈哈。

      我觉得,如果你不使用形码,不用码表不用辅码,那么使用落格输入法的意义并不是很大,因为纯用双拼的话,用搜狗更好用,整句输入比我做的算法精确多了!(毕竟人家有亿级别的语料库不是?)哦,还有云词库哈哈。

  16. 方便留个微信或者qq吗
    我是输入法引擎开发者 想再自己mac上写个demo 参考了您的文章但是依然跑步起来 能不能帮指点下 我微信 nullin 多谢

  17. 又来打搅了,想请教一个主题修改的问题,2017主题中文行距很小,字一多很难看,想请教怎么改,还有就是页面宽度比较小,我想调宽一点,请问可以怎么设置下,我折腾很久还没找到更改的地方,谢谢!

    1. 在主题的自定义中,选择“额外 CSS”,在里边输入
      .wrap {
      max-width: 1500px;
      padding-left: 3em;
      padding-right: 3em;
      }

      其中的max-width: 1500px;就是总宽度,你看心情改 :)
      下边的代码也贴进去,就可以控制正文与侧边栏的具体宽度,按照总宽度的百分比计算的,你改着试试,都是实时生效的,注意别把总和大于90%就好不然不好看了就。
      .has-sidebar:not(.error404) #primary {
      float: left;
      width: 62%;
      }

      .has-sidebar #secondary {
      float: right;
      padding-top: 0;
      width: 30%;
      }

      至于行间距,贴入下面的代码:
      @media screen and (min-width: 48em) {

      /* Typography */

      body,
      button,
      input,
      select,
      textarea {
      font-size: 16px;
      font-size: 1rem;
      line-height: 2.5;
      }
      其中的line-height: 2.5;就是行间距,默认是1.5

    2. 嗯,经测试,具体左右栏宽度的百分比这个就不要改了,只改总宽度以及行间距即可,否则在手机上的浏览效果不佳,具体你也可以自己改好了手机打开博客试试看哈。

  18. 请问一个小问题,wordpress主题更新到2017后,底部的Proudly powered by WordPress在哪里修改呢,我原来在foot中更改,但现在更改不起作用,因为编程比较菜,麻烦详细解答下,谢谢!如贵站更改:
    落格博客 | 2011-2016 © CopyRight | Proudly powered by WordPress

    1. 还麻烦问下,像采用两栏布置时,左边标题栏下会有很大一块空白,能在哪里修改增加填充内容,或者采用一栏时,页面宽度有限制,能否增加(对于页面,非文章),谢谢

      1. 改这个css在style.css文件里,总之,你可以这样来修改:
        在这个主题的自定义界面里,最下方的选项“额外CSS”,进入其中,在输入框最下边另起一行输入以下内容即可
        .blog:not(.has-sidebar) #primary article,
        .archive:not(.page-one-column):not(.has-sidebar) #primary article,
        .search:not(.has-sidebar) #primary article,
        .error404:not(.has-sidebar) #primary .page-content,
        .error404.has-sidebar #primary .page-content,
        body.page-two-column:not(.archive) #primary .entry-content,
        body.page-two-column #comments {
        float: right;
        width: 78%;
        }

        同时,里边的width: 78%;就是你想要的宽度,自己调整为喜欢的宽度即可。

    2. 由页脚文件代码中的这句get_template_part( 'template-parts/footer/site', 'info' );可知,关于页脚声明的文件位于主题目录的template-parts/footer/site目录下,有一个 site-info.php 文件。

  19. 你好,大侠,我有个网络问题想请教一下,我家里有个linksys WRT1900acs的路由器,我想把shadowsocks装在这个路由器上,但我在网上查到的资料是大家都下载shadowsocks软件然后每月交费使用别人(该公司)提供的流量来上外国网站,不知道我理解的对不对,我是电脑白痴,我想在路由器上装自己操作并使用的shadowsocks,我自己已经有vpn账号了,请问我改怎么弄呢?求指点,请问可以加你qq私聊吗?

      1. 你好,我想说的就是shawdowsocks,想请教下怎么才能把ss装在wrt路由器上,我没有jabber,是否可以告诉我您的gmail邮箱?

  20. 请问 落格输入法支持iOS10吗?
    AppStore已购买,下载多次,进度显示快完成了,可过一会儿都提示暂时无法下载。iPhone7,iOS10.1.1

    1. 落格输入法支持iOS 8 以上版本,在iOS 10 有最好的使用体验。嗯,最好不要再用8了。

      今天我也遇到了这个问题,可能是苹果自身cdn问题,试试看换个网络或者过一会儿再下载即可。尝试更换dns为114.114.114.114再重新下载。
      不行就取消下载然后到“已购”里手动下载。

      落格输入法是通用app,iPhone iPad iPod 都可以使用。

      1. 由于 swift 语言本身问题,目前无法使用 swift 语言开发 Mac 版落格输入法,相信我,我比你还急。等iOS版稳定之后,我会考虑用oc语言来写mac版(如果swift还是不行的话)

        1. 呃,落格输入法 只有一个 telegram 群,而它被国内屏蔽了。你要是想加……可以考虑加一下小鹤双拼的官方群,我也在群里的。182883808 ——进群需要一块钱哈:)

  21. Git了你的Aliyun-DDNS-client这个东东在应用的时候 出现了以下错误,博主有空的话帮看看哟, 我邮箱3117821@qq.com

    ubuntu@ubuntu:/opt/aliyun-ddns-client$ python ddns.py
    Traceback (most recent call last):
    File “ddns.py”, line 21, in
    from helper import DDNSHelper
    File “/opt/aliyun-ddns-client/helper.py”, line 20, in
    from utils import DDNSUtils
    File “/opt/aliyun-ddns-client/utils.py”, line 20, in
    import requests
    ImportError: No module named requests

    结束

          1. [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (timthumb.php, line 0) http://cubernet.cn/wp-content/themes/traveler-2/timthumb.php?src=http://cubernet.cn/wp-content/uploads/2015/11/wpid-2015-07-24-diary-1.jpg&h=65&w=90&zc=1 比如说这样。

    1. 这个没有什么方法(合法的话),首先我的网站收录比较多是因为它里边写的内容多,其次是内容大都原创,再次是这个博客稳定运行了五年。你的网站内容相对少,所以肯定收录量就少——因为本来就那么几个页面。其次的话,就是 SEO了,SEO全称是搜索引擎优化,目的是为了让搜索引擎能够更好地访问你的网站,这样它们就会收录的更多,给你的网站打分更高,比如说页面的伪静态(以.html结尾),网站整体缓存(打开更快),使用一些SEO插件(Yoast SEO)它一条龙服务帮你完善页面里的细节信息,人眼看不到,但搜索引擎会看到,这样就会对搜索引擎更加友好。最后,去各大搜索引擎注册站长,一个是能看到你博客的收录量,另一个就是(潜在的)增加收录量。最重要的就是要原创内容,如果你坚持每个月写几篇比较高质量的文章,那么很快相关的搜索量就上去了。

    1. 你的博客没有友链呢?加个友链功能交换链接哈~
      我这个是全站伪静态,其实还是动态的,只是让它看上去是静态的了。另外配合预缓存,所以可能你浏览器来也会感觉是静态的:)

  22. 唔…留言板最上面的PGP的那个链接是404的?通过搜索找到了CN PGP和NetPGP, net的是你gmail邮箱的,那个cn是hotmail,我该用哪个?刚刚服务器的mysql挂了,大半夜后台被暴力破解了1000多次,桑心啊

  23. 你好。我路由器刷完openwrt,安装完shadowsokcs之后,能登陆google。但是不能登陆其他网站。我也不知道该怎么配置这个路由器。明月永在的openwrt五一版本。我是否可以请教下你啊。付费也可以。如果您愿意,我可以加您微信么?我的微信:(安全起见,我给你隐藏了。)

    1. 能登录google不能登录其他gfwed网站,首先你ss搭建正确,其次你能登录google是因为google直接断线而其他域名是污染。你试试把你的DNS换为 115.29.49.136 看看能不能打开。主要还是你ss配置的策略,你看看是不是用的默认的而你没有添加之类的?

  24. Hi,
    本人因为玩 PS4 的网络缓慢问题饱受煎熬。因此购入了网件 3800 路由器,并且刷了 Openwrt 使用 Shadowsocks。一开始看上去很顺利,可以我很快发现三个首字母分别为 Y、F、T 的外国网站上不去。后来才接触到 DNS 污染这个概念。结果从网上搜索到您这篇文章——https://www.logcg.com/archives/860.html 。可是,我只是一名普通的用户,理解不了大神们说的那些使用命令行如何添加插件。不知道您可以教我如何操作么?我目标很简单,能上 Y、F、T 网就行。

    Best Regards,
    PG

    1. 你的意思就是说,你完全不懂 CLI 命令了对吧?
      那假定你的 shadowsocks 完全搭建对了而且能够生效,那么我推荐你的 DNS 加密软件:DNS Crypt
      这个软件由 opendns 开发,我给你它的 github 项目地址,你在里边可以找到 GUI (图形界面)的软件版本,包括 Windows osx Linux 都有https://github.com/opendns/dnscrypt-proxy
      优点是安装到电脑上一键规避污染,不用梯子都可以上 Dropbox~
      缺点是可能访问一些国内网站不会享受到 cdn 加速了——你要是不知道什么是 cdn,那就无视掉这句话吧:)

      1. 首先感谢您的回复。DNS Crypt 为我提供了一个新的解决思路。
        只是,我也希望在手机端、PS4 端浏览 Y、F、T 网,可惜 DNS Crypt 没有对应平台客户端。另外,我在Android、Windows 和 OS X 平台上使用的 Shadowsocks 软件使用全局代理时能够正常浏览 Y、F、T 网。
        我最初的想法是,买了一个支持 Openwrt 的路由器,就能够一劳永逸地翻墙,无需再在任何平台上安装其它软件。
        所以,我在想是否能在路由器上使用命令行作改动?我认为这算是根本解决之道,请赐教 🙂

        Best Regards,
        PG

  25. 在你们论坛上发现有openwrt 的一些东西,目前小弟在移植openwrt 到tiny6410开发板上,boot,kernel,rootfs都已经烧录好了,可以可pc机,虚拟机通信,luci已经安装,www目录下面有index.html文件,但是luci打不开,ssh都是可以登录板子,希望可以获得指点,谢谢!
    注:tiny6410开发板只有一个有线网口,不知道网络接口是否配置错误
    root@DreamBox:/etc/config# cat network
    # Copyright (C) 2008 OpenWrt.org

    config interface loopback
    option ifname lo
    option proto static
    option ipaddr 127.0.0.1
    option netmask 255.0.0.0

    config interface lan
    option type bridge
    option ifname eth0
    option proto static
    option ipaddr 192.168.1.1
    option netmask 255.255.255.0
    root@DreamBox:/etc/config#

    1. 看你这样子应该一切安装正常了,那么你开启服务了吗?使用下面命令激活HTTP服务器然后试试?
      1./etc/init.d/uhttpd enable
      2./etc/init.d/uhttpd start
      (╮(╯▽╰)╭其实研究这个的那哥们弃坑了,都是博主一直在慢慢填坑……)
      另外,这是博客不是论坛呀?

    1. 你好,首先一点是我建议你让它变砖。一方面这东西你配置起来有些麻烦;另一方面这个设备本身带有端口隔离的功能,而且这个功能不可以被取消掉——即你所有通过这个AP接入的无线设备是不可以互相通信的。所以如果你家用路由,很多功能就消失掉了:比如手机传图,比如电脑电视互通,比如AirDrop等等等等,凡事需要局域网互通的功能就都跟你说拜拜了。我拿到这个路由也是巧合,玩了玩就扔到箱子里吃灰了,这个东西,不好用。哦对了,它带宽好像还不大,功率是高了些,这不还辐射大了嘛。

发表评论

电子邮件地址不会被公开。 必填项已用*标注