分类
Mac OS

使用 xcode-install 来管理 Xcode 版本

我们都知道,在使用 Python 的时候有 pyenv,使用 ruby 的话有 rbenv,都能方便地控制和管理编程语言环境的版本,那么,有没有什么方法,能让 Xcode 也像这样切换版本呢?

每次 Xcode 发布更新,更还是不更成了一个问题,下载难,还不能断点续传,又不能用第三方工具下载,真的是非常要命……就更别提多个版本时候的兼容问题了。

使用 xcode-install,一次性解决这些问题,耶!

它是一个专门用来管理 Xcode 版本的工具,可以一键切换不同版本的 Xcode,在你的 Mac 上安装多个版本的 Xcode,非常方便。

首先,使用命令安装它: gem install xcode-install ,

然后是更新可用版本列表: xcversion update ,不过由于是要从苹果开发者网站拉取所有可用版本列表,所以需要你的开发者登录账号和密码,这些会保存在本地 iCloud 钥匙串当中,不用担心。

输入后你很有可能会遇到如下报错:

这是由于你当前已经安装了 Xcode 导致的,这阻止了 xcode-install 创建链接,所以,根据你当前安装的 Xcode 版本,将现在已经安装的版本改名,比如我现在安装的版本是最新的 11.5,那么就把 Xcode.app 改名为 Xcode-11.5.app ,然后再重试即可。

更新列表后就可以根据列表中的版本号进行安装了,你可以看到,在版本列表中,11.5 的版本已经安装:

就使用命令 xcversion select 11.5 让当前 Xcode 生效。

使用 xcversion selected 来验证:

现在 xcode-install 已经能正确识别我们原本安装且正在使用的 Xcode 版本了。

注意如果版本号里包含空格,比如测试版,那么需要用单引号将版本号括起来,使用命令安装另一个版本的 Xcode:


当然,这个工具是使用 curl 进行下载,其实延时等待时间没什么特殊优化,如果你用浏览器下载很容易断,那用这个工具也是一样,只是版本管理比较方便……

本文由 落格博客 原创撰写:落格博客 » 使用 xcode-install 来管理 Xcode 版本

转载请保留出处和原文链接:https://www.logcg.com/archives/3377.html

由落格博客

如非声明,本人所著文章均为原创手打,转载请注明本页面链接和我的名字。

发表评论

电子邮件地址不会被公开。 必填项已用*标注